Spey Pages banner

1 - 2 of 2 Posts

·
Here we go again!
Joined
·
620 Posts
Discussion Starter · #1 ·
Bought a new Ultralite DD 7000 about a year and a half ago. It has seen very light use, I barely get out anymore. The spool now rubs the frame when winding, specifically where the handle is when coming around bottom and back up (torque/twist applied). You can grab the spool handle and the frame and pull, getting separation where there should be none. Something is amiss, there is suddenly slop in the tolerance, play between the spool and frame. There was none, and suddenly there it was. The spool had not been removed from the reel for quite some time. Took it apart, nothing seems out of order, and there is nothing but the center locking nut that comes off so I don't see where something (like a gasket or spacer) could have come free. Any ideas?

I wrote immediately to Hardy using the contact us form and got an automated "We'll get back to you" response, but no response ever came after that. It has been a while.

Anyone know someone connected with Hardy USA who might have some answers? Not sure what the warranty was but it was probably only a year.

Thinking I should have listened to that little inner voice wondering if I really wanted to chance the Korean/non English made reels. Expensive shiny rubbish it is, at the moment.
 

·
Banned
Joined
·
894 Posts
When the button release screwed up on my demon 7000 I emailed Hardy and they responded promptly and advised me to mail it to them. I got it back within a couple weeks, fully rebuilt for free. No issues here with Hardy, it's also a freshwater reel used in salt
 
1 - 2 of 2 Posts
Top