Echo SR 10'6" 4wt Question - Spey Pages
 
LinkBack Thread Tools Rate Thread Display Modes
post #1 of 4 (permalink) Old 10-10-2015, 08:14 PM Thread Starter
Registered User
 
Join Date: Nov 2007
Location: Olympic Peninsula
Posts: 23
Echo SR 10'6" 4wt Question

I recently had the opportunity to use my Echo SR 4wt for the first time fishing for trout, using a 6wt (nominally 235gr) Ambush line. Casting a small soft hackle with a 10' intermediate Airflo trout poly leader with a few feet of 3 or 4x for tippet I most often could not get the cast to lay out. Instead it would flop off to the side rather than fully extend even in the absence of any substantial wind. It was only a bit better with a moderately weighted bugger off a 7 1/2' 2.6ips sinking poly leader tipped with a few feet of 2x.

I don't know if the problem is in my casting, the line/leader set-ups, or both. Any suggestions on what I might do to get the casts to lay out would be greatly appreciated.

Andy
afried is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 10-18-2015, 04:54 PM
Registered User
 
Join Date: Feb 2010
Location: Qld Australia
Posts: 1,220
Leader set up etc sounds fine, and wouldn't be the cause.
I beleive it sounds like your rod tracking during your foreward cast.
Your line ultimately follows true to the tip travel path.
That and possibly your target, aim a little higher to allow everything to unroll before it lands.
But hooking casts are generally caused by your tip travelling a bit skewif on the forward cast.
ozswitch is offline  
post #3 of 4 (permalink) Old 10-21-2015, 02:39 PM Thread Starter
Registered User
 
Join Date: Nov 2007
Location: Olympic Peninsula
Posts: 23
Thanks for the tip. I'll definitely try to concentrate more on those aspects of the cast next time out with that rod. Andy
afried is offline  
Sponsored Links
Advertisement
 
post #4 of 4 (permalink) Old 10-21-2015, 07:28 PM
Registered User
 
Join Date: Oct 2012
Location: McKenzie
Posts: 285
I had this exact setup and it cast very well so it is probably the tracking issue mentioned above.
spfd jason is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Spey Pages forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes Rate This Thread
Linear Mode Linear Mode
Rate This Thread:



Similar Threads
Thread Thread Starter Forum Replies Last Post
FS: Echo SR 10'6" 4wt Softhacklejones Spey Classifieds 6 09-20-2015 09:20 AM
Echo 10'6" 4wt Switch ifisherman Spey Classifieds 2 12-02-2011 07:43 PM
Echo 10'6" or Deer Creek 11" 4wt Switch? fatman Rods 4 01-11-2011 01:15 AM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome